Release: Star Rod modding tools + Paper Mario Pro Mode « 1 ... 16 17 18 19 20 »
Users browsing this thread: 1 Guest(s)

Hey, I joined cause of this program, I want to have some fun with it.
I put everything in the zip in a folder, but got this:
[Image: starroderror.png]
why is this?

I made a tool for managing images in spritesheets, namely adding new ones and modifying existing palettes. If you're interested in that, here's the thread for it:
http://origami64.net/showthread.php?tid=814

All i basically did was changing the background of a map, mac_01.map to be specific.
But i just get two errors before it crashes when i open it in Project64.

http://imgur.com/6uKOjcz
http://imgur.com/Y5X4QRW

I have no idea what i could try else, thanks in advance!

Have you looked at my tutorials here yet? (<-- hint: clickable) Are you using Project64 1.6? If so, then maybe because you haven't set it to 8MB on advanced settings.
(This post was last modified: 08-08-2017, 08:35 PM by SmithJrBlaquaLuigi.)
I'm not replying to your Damn Thread if nobody understands what you're saying.

This post has been sent from Microsoft Surface Pro Windows 10

I really don't understand this, I tried a different sprite same exact methods same exact dimensions and it worked perfectly, return to my previous sprites that failed earlier same exact method same exact dimensions and it failed again with a fatal error during emulation. I really want to make mods for Paper Mario, but this is almost impossible. I can't make any form of consistent changes or style if it's random whether or not a sprite works with no user error what so ever. As I repeated the same exact steps the same exact dimensions the same exact index process.

Whether I edit them manually or use the sprite converter it's completely random if they work or not, it really feels like the program somehow cherry picks issues with the images, even though I know that's impossible.

I'll use one example, this isn't a mod I'm actually working on I'm just using these sprites to learn how to use it.


Sprite set #1 Kirby

I add the animations replace the existing ones for Kooper, they display perfectly in Star Rod it compiles correctly as well, I jump to in game switch to Kooper it displays perfectly the animations work the colors are fine.

Game runs fine there are no issues what so ever.

Sprite Set #2 Waddle Dee
I use an exact duplicate of my Paper Mario dump the same one I used for Kirby. I add the animations replace the existing ones for Kooper, they display perfectly in Star Rod it compiles correctly as well, I jump to in game switch to Kooper.

A Fatal Error has occurred stopping emulation.


Kirby and Waddle Dee are the same size, so everything is the same except for the way the character looks, both were converted to the proper image type and colors, both had properly configured palettes.

Anyways rant over, this wasn't directed at anyone at all. I love that this tool exists and I know it's made for free in the author's spare time. This is simply my own frustration with how utterly confusing this issue is, and it doesn't seem to be user error on my part at least I hope not.

Edit :

I managed to get the crash handler to load instead of just outright crashing the emulator, and this only happens with the sprite set that doesn't work.

[Image: N1Ss1U3.png]
(This post was last modified: 10-08-2017, 06:17 AM by Sir_Waddle100.)

I've done all he steps to play pro mode, but I never received Project64 Settings.txt. Could someone create a download link with them? It seems I can't get them any other way.

(10-08-2017, 07:51 PM)Ryan McCrohan Wrote: I've done all he steps to play pro mode, but I never received Project64 Settings.txt. Could someone create a download link with them? It seems I can't get them any other way.






I'm not replying to your Damn Thread if nobody understands what you're saying.

This post has been sent from Microsoft Surface Pro Windows 10

Something I thought I'd mention, I don't know if this has been said before. I'm pretty sure Paper Mario Pro Mode is incompatible with Project64 v2.2. If anyone has updated the RDB, set the 8mb memory and it still isn't working, make sure you use version 2.3.

(11-08-2017, 11:23 PM)UltPokenonFan Wrote: Something I thought I'd mention, I don't know if this has been said before. I'm pretty sure Paper Mario Pro Mode is incompatible with Project64 v2.2. If anyone has updated the RDB, set the 8mb memory and it still isn't working, make sure you use version 2.3.

Something I thought I'd mention, I'm pretty sure Paper Mario Pro mode is compatible with Project64 1.6 except newer versions. If you updated the RDB, and set it to 8MB correctly, It will work. Make sure you use version 1.6.

With that aside, 2.2 and 2.3 are buggy and horrible. Because someone posted a screenshot of blue screen crash after loading Star Rod.
(This post was last modified: 12-08-2017, 02:13 AM by SmithJrBlaquaLuigi.)
I'm not replying to your Damn Thread if nobody understands what you're saying.

This post has been sent from Microsoft Surface Pro Windows 10

It does work with 2.2 though, I've played through the entire pro mode storyline using these settings and plugins.

[Image: TJ6EDQy.png]

[Image: LIT3WnQ.png]

Currently I'm doing all the challenges on it as well.
(This post was last modified: 12-08-2017, 04:03 AM by Sir_Waddle100.)

Release: Star Rod modding tools + Paper Mario Pro Mode « 1 ... 16 17 18 19 20 »
Users browsing this thread: 1 Guest(s)


  EN ・日本語