MK64 Pitstop (V.0.0.5.1 Beta) « 1 ... 7 8 9 10 11
Users browsing this thread: 1 Guest(s)

I have a project in mind I'd really love to use this for, but I cannot for the life of me get PitStop working. Chomp Shop runs fine, but the main editor lags eternally on "Reading TKM00 Textures" when I try to create a new project. Using Windows 10, no clue why it gets stuck.

EDIT: My bad, turns out I was using the PAL version. You need the American rom for it to work.
(This post was last modified: 22-06-2017, 10:06 PM by DryBoney.)

Sorry to double post, but I'd like to know how the texture editor is coming along and when we can replace every stage texture as seen here.

(14-12-2016, 11:00 PM)mib_f8sm9c Wrote: [Image: Czq9qhhVQAEb3zm.jpg]

No worries, I've been gone a lot so I can understand the fear of not being heard. The last release of Pitstop has all the textures, you just gotta dig in the list to find them.

https://github.com/mib-f8sm9c/Pitstop64/releases/tag/V0.0.5.0

I don't think it's perfect, there's a lot of MIO0 encoded textures which don't have specific pointers in the code for them, so if you try to replace them, they have to be replaced by textures with smaller encoded size that can overwrite the old data. More generally speaking, if a texture is MIO0 encoded, you'll need to make sure the texture you replace it with is not a complex image with lots of blended colors, otherwise it'll probably not save correctly.

Better texture replacement will be a feature that gets released with the Track Shack I'm developing, but I'm stuck on a particularly rough nugget of a roadblock with the 3d rendering currently.

Let me know if you need more help after this.

Just tried it. Can't get the rom to load, unfortunately. Also tried the PAL and Japanese roms just to be sure, and no luck. It either crashes or loads indefinitely. It could just be an issue on my end though. Not sure.

Good news guys, I finally figured out the cause behind the crashing. It's be a dumb fix, but I'll work on it tonight/tomorrow and try to get out a FUNCTIONAL V0.0.5.1 soon. Also I'll be getting in that bulk import that MRKane was suggesting (though for now we should keep the wheels in the image. I don't think I ever quite the wheels palettes fixed up for proper importing)

Alright, I uploaded a new version. This one should have the fix for the initial loading crash. I don't have a computer to test it out here, so let me know if it's still crashing.

Also, on what MRKane's been working on, this version has a new button to auto-assign animations to loaded images if they are generated using MRKane's Blender file. The button is in the image-loading form and should enable once you load all the images in (there should be 321 images per kart total).

I had to change the blender file to get the animations lined up and looking smooth (seems like my previous assumption of a 25 degree kart incline was way too much). I've included the modified blender script below. You MUST use that one to import the images correctly.

Pitstop V.0.0.5.1 Installer

MRKane's Kart Blender File (MODIFIED)


[Image: yDCGIFS.gif]

I'm pretty bad at blender, so I didn't bother trying to load in the textures on the model import, lol. Also enjoy that mouse in the picture too.
(This post was last modified: Yesterday, 01:58 AM by mib_f8sm9c.)

Outstanding! That looks fantastic!

I'll be sure to get right onto it over the next few days (would you believe I don't actually own a computer so can only use the ones at my work?) and see what I can manage to mill out. I guess Sonic and Link will be first, and perhaps also Jazz Jackrabbit Wink

I'll be sure to put new blend files up as I continue to develop things Smile

So that was brilliantly easy!!! Link isn't my favourite character, but he was the accurate proportions one that I decided to roll with, here's a file for all of you to try out and have fun with!

http://s000.tinyupload.com/?file_id=53014370634993653075

So the most obvious thing here is the black outline around the character, which is obvious enough on emulator but might not show up on actual hardware. I could only assume that it's got to do with the alpha background on the PNG bleeding through the image itself - which means that I'll need to come up with a cunning setup in Blender to render things a bit better.

After years of hacking I've finally added a new character thanks to your efforts - really brings out the kid in me Wink
(This post was last modified: 3 hours ago by MRKane.)

MK64 Pitstop (V.0.0.5.1 Beta) « 1 ... 7 8 9 10 11
Users browsing this thread: 1 Guest(s)