SM64 Editor 2.1.4 « 1 ... 8 9 10 11 12 »
Users browsing this thread: 1 Guest(s)

when I try to import a model into the 64 version (mario's head is the one I'm trying to replace), it tells me, model exceeds filesize try reducing the number of textures, but the thing is I can't reduce the number of textures because the model would be really screwy, unless I do colors, but then I tried colors and the eyes as the only texture and it still told me to try reducing the number of textures and I do not know why it's doing this, the DS version of Mario 64 can handle way more textures of larger sizes and models up to over 300 faces for the head, I reduced the amount of faces to under 300 to see if it'll work and it still didn't work for some reason and that bugs me, and I thought the Nintendo DS version was supposed to be the weaker version of Super Mario 64, but this annoyance with the importing seems to be telling me otherwise

EDIT: nevermind, my problem is solved, all I had to do was lower the face count from over 300 to around 190 faces
(This post was last modified: 08-09-2017, 03:35 AM by LarryKoopaIsAwesome. Edit Reason: I solved my problem )

One of the presets in 2.0.8 is broken, here's the fixed version. Re-apply the 0x04 bank tweak if your ROM broke.


Attached Files
Size: 316 bytes / Downloads: 17 .xml   Mario (Ext.) - Bottom.xml


The 0x04 Bank Tweak causes Kaze's MOP behaviors to not work properly. In particular, the Flipswitch and Flipswitch Star Spawner objects. This is likely caused by conflicting ROM addresses (maybe I should decrease the tweak's value?)

Whenever I try to import any music into a slot in the SM64 Editor 2.0.9 it always tells me to re-import and apply instrument sets even if I did it over 4 times. The music does import in fact, however, the instrument set won't change and it irritates me. It bugs me a lot because I have to use v2.0.8 to import the music and make themes out of v2.0.9. Note that this happens in any rom hack I open and it ruins the music that is already in the rom. I need a way to fix this because I import themes all the time when it comes to importing custom sounds too. I'll stick to 2.0.8 until anybody finds a solution for this.
(This post was last modified: 14-09-2017, 07:07 AM by Mosky Juarez.)
If the midi to m64 tool is done, I might give it a try and see if it sounds better than my m64s.

Re-download 2.0.9, I fixed that shortly after uploading.

(14-09-2017, 10:20 AM)Skeletons Wrote: Re-download 2.0.9, I fixed that shortly after uploading.

Okay. Thank you for informing me about it.
If the midi to m64 tool is done, I might give it a try and see if it sounds better than my m64s.

Hello!! I'm literally new on this side (editing) since I've been more like in the (gaming) side. Playing mods, hacks, etc.

It was until Kaze suddenly created the SM64O and added that Princess Peach Model I personally don't like that much, I'm a fan of Peach and I think she looks better in the Mario Party 64's models so I encouraged to LEARN how to do this and go for it, create that model myself, after that intro I make my question hahaha.

I got the Editor and I have Google SketchUp 8. It took me a while to create Peach's dress but the v0.1 is ok (ugly) but ok, and whenever I try to import it, it says "perfectly imported blablabla" ok but ingame there's nothing there so I decided to try it replacing the "head" and there's nothing either. Tried creating a really small cilinder and I figured out that the dress was even bigger than the castle because I could barely see the cilinder on Mario's head but even though the cilinder was perfect size it's like half invisible, half visible. No matter what shape I do it just won't appear when I import it and I don't know what am I doing wrong T_T

(17-09-2017, 05:07 AM)MissDessire Wrote: Hello!! I'm literally new on this side (editing) since I've been more like in the (gaming) side. Playing mods, hacks, etc.

It was until Kaze suddenly created the SM64O and added that Princess Peach Model I personally don't like that much, I'm a fan of Peach and I think she looks better in the Mario Party 64's models so I encouraged to LEARN how to do this and go for it, create that model myself, after that intro I make my question hahaha.

I got the Editor and I have Google SketchUp 8. It took me a while to create Peach's dress but the v0.1 is ok (ugly) but ok, and whenever I try to import it, it says "perfectly imported blablabla" ok but ingame there's nothing there so I decided to try it replacing the "head" and there's nothing either. Tried creating a really small cilinder and I figured out that the dress was even bigger than the castle because I could barely see the cilinder on Mario's head but even though the cilinder was perfect size it's like half invisible, half visible. No matter what shape I do it just won't appear when I import it and I don't know what am I doing wrong T_T

It seems that your model is scaled up too much, try scaling it down or repositioning it.
Working on a major hack behind closed doors. (for better marketing.) If you're interested, check out the dedicated Discord server: https://discordapp.com/invite/mEGVN5u

(17-09-2017, 02:28 PM)BaconBoy Wrote:
(17-09-2017, 05:07 AM)MissDessire Wrote: Hello!! I'm literally new on this side (editing) since I've been more like in the (gaming) side. Playing mods, hacks, etc.

It was until Kaze suddenly created the SM64O and added that Princess Peach Model I personally don't like that much, I'm a fan of Peach and I think she looks better in the Mario Party 64's models so I encouraged to LEARN how to do this and go for it, create that model myself, after that intro I make my question hahaha.

I got the Editor and I have Google SketchUp 8. It took me a while to create Peach's dress but the v0.1 is ok (ugly) but ok, and whenever I try to import it, it says "perfectly imported blablabla" ok but ingame there's nothing there so I decided to try it replacing the "head" and there's nothing either. Tried creating a really small cilinder and I figured out that the dress was even bigger than the castle because I could barely see the cilinder on Mario's head but even though the cilinder was perfect size it's like half invisible, half visible. No matter what shape I do it just won't appear when I import it and I don't know what am I doing wrong T_T

It seems that your model is scaled up too much, try scaling it down or repositioning it.

Dead I just tried that and it doesn't seem to work either, I made a square, it appears where it should, but it's half visible and half invisible... Sad I'd really appretiate your help here, please :c

(17-09-2017, 04:35 PM)MissDessire Wrote: Dead I just tried that and it doesn't seem to work either, I made a square, it appears where it should, but it's half visible and half invisible...  Sad   I'd really appretiate your help here, please :c

Is your square made up of two triangles? In my experience, everything in SM64 must be made of triangles, sort of like this:

Spoiler :
Code:
_________
|\      |
| \     |
|  \    |
|   \   |
|    \  |
|     \ |
|      \|
---------


(Sorry about the crude ASCII art, but i didn't want to go to the bother of taking a screenshot. I'm lazy. Wink )
(This post was last modified: 20-09-2017, 01:36 PM by J_128. Edit Reason: Fix italics tag )
Quote:A word fitly spoken is like apples of gold in pictures of silver.
  --Proverbs 25:11

SM64 Editor 2.1.4 « 1 ... 8 9 10 11 12 »
Users browsing this thread: 1 Guest(s)


  EN ・日本語