Toad's Tool v0.6.7S « 1 2 3 4 5 ... 9 »
Users browsing this thread: 1 Guest(s)

(28-09-2016, 12:34 AM)Skeletons Wrote: It could be that you don't have shockwave installed.

It was working before though. And when I downgrade the build it works again. But I'll try that.

Well, that didn't work.
(This post was last modified: 28-09-2016, 12:53 AM by BaconBoy.)
If you like original and fun to play content, check out my current major Super Mario 64 romhack, Superstar Plumber!

(28-09-2016, 12:34 AM)Skeletons Wrote: It could be that you don't have shockwave installed.

I never had installed shockwave.
Now i installed shockwave but TT64 still wont start.
And i can't see the process in the task manager.
(This post was last modified: 28-09-2016, 12:22 PM by Pilzinsel64.)

(28-09-2016, 12:21 PM)Pilzinsel64 Wrote:
(28-09-2016, 12:34 AM)Skeletons Wrote: It could be that you don't have shockwave installed.

I never had installed shockwave.
Now i installed shockwave but TT64 still wont start.
And i can't see the process in the task manager.

Same. And "Adobe Director" pops up for a split second in task managers and disappears immediately.

Please just update it Skelux. At list make a 0.6.2a update, you can do the rest on a major update. I just need this working.
If you like original and fun to play content, check out my current major Super Mario 64 romhack, Superstar Plumber!

Yeah I have been seeing a lot of glitches with toadtool like crashes and some of the act stars disappearing

(27-09-2016, 12:23 PM)Pilzinsel64 Wrote: I have the same problem. Since i updated my Win 10 to Version 1607 TT64 wont start!

I'm not saying that Win 10 isn't a problem for some of you, but Win 10 Version 1607 still runs TT64 0.6.2S fine for me. I am not running with any compatibility settings, but have any of you tried them (Properties->Compatibility)?
[Image: YDCxKXA.png]

(28-09-2016, 12:34 AM)Skeletons Wrote: It could be that you don't have shockwave installed.

Using Dependency Walker, "Toad's Tool 64 v0.6.2S.exe" only depends on the following DLLs: KERNEL32.DLL, USER32.DLL, GDI32.DLL, ADVAPI32.DLL. None of these are shockwave, so I don't think Shockwave is a dependency. I also do no have shockwave installed.

(28-09-2016, 08:04 PM)BAC0NB0Y Wrote: Please just update it Skelux. At list make a 0.6.2a update, you can do the rest on a major update. I just need this working.

Asking for an update when we can't reproduce the problem and there is no known solution is not helpful.

(29-09-2016, 02:16 AM)queueRAM Wrote:
(27-09-2016, 12:23 PM)Pilzinsel64 Wrote: I have the same problem. Since i updated my Win 10 to Version 1607 TT64 wont start!

but have any of you tried them (Properties->Compatibility)?


Using Dependency Walker, "Toad's Tool 64 v0.6.2S.exe" only depends on the following DLLs: KERNEL32.DLL, USER32.DLL, GDI32.DLL, ADVAPI32.DLL. None of these are shockwave, so I don't think Shockwave is a dependency. I also do no have shockwave installed.

Yes I have.
And also I tried DW;
Error: At least one required implicit or forwarded dependency was not found.
Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Error: Modules with different CPU types were found.
Warning: At least one delay-load dependency module was not found.
If you like original and fun to play content, check out my current major Super Mario 64 romhack, Superstar Plumber!

(29-09-2016, 12:30 PM)BAC0NB0Y Wrote: And also I tried DW;
Error: At least one required implicit or forwarded dependency was not found.
Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Error: Modules with different CPU types were found.
Warning: At least one delay-load dependency module was not found.

Those are expected under Windows 10. My point about depends.exe was that TT64 doesn't depend on Shockwave which you should also see.
(This post was last modified: 29-09-2016, 04:09 PM by queueRAM. Edit Reason: add link )

Personally I've not had any issues with Windows 10 running with an APU.

If I'm allowed to request an addition, would it be possible to expand the textures screen to include all textures and label to a point what each texture is? That's one thing I've always wanted to see in the editor and could never see a reason why some textures are simply excluded. I know there are some tools out there that allow a person to manually put in values to export and import textures but for entry-level users like myself it's very intimidating to have to put in the values for each texture (plus it'd be a luxury to have it there and easily accessed).

I also can't launch under the latest update with Windows 10 Home 64-bit, but I think it's worth noting that upon updating to the Anniversary Update, it did remove at least one of my drivers off the computer. I don't know if that information helps at all, but it does give some insight that the AU could have messed something up.

After doing research with several of you to try to find out the source, here's what we have so far:
-At runtime, TT64 extracts .dll files for shockwave into a temporary folder in AppData (Tempfolder.aa*)
-When TT64 closes successfully, it deletes the .dll folder
-When TT64 doesn't close successfully, it keeps the .dll folder and creates a new one
-The problem .dll (from the crash reports) appears to be IML32.dll, which is located in the temporary folder
-The 2 crashdumps occur 2 seconds after each other, and have been pasted on pastebin (http://pastebin.com/a4mEYWnF, http://pastebin.com/aXNeUr5y)
-Dump files have been generated by procdump and uploaded (https://www.mediafire.com/folder/b2vuu72fgzyed/DMP)
-TT64 works on a fresh install of W10 1607.
So, for working for only half of the people using it, this seems incredibly specific.

Toad's Tool v0.6.7S « 1 2 3 4 5 ... 9 »
Users browsing this thread: 1 Guest(s)